iPhone 4 – stuck between generations

I want an iPhone 4.

Even with the well publicized reception problems, it’s probably better than the one I’m using now:  the original iPhone 2G. The reception was great when I got it (which is why I decided, shortly thereafter, to do away with the home phone).

But it’s not the same now as it was then, three years ago.

The signal has been degrading ever since the iPhone 3g was introduced. There are only a couple of rooms left in my house that I can use.  I drop calls all the time.  I’m eligible for an upgrade, and almost ready to buy it.

Because of AT&T’s lousy reception, I would possibly switch phones and carriers altogether, but I enjoy the iPhone.

I got my iPhone before the App Store existed.  Switching from years of Palm use, I sorely missed the absence of a to do list — but I managed with iCal.

Then came the apps, and it hasn’t been a big deal for me.  But there are a couple I us a lot.

Put Things Off (the most simple and best task management system I’ve ever used).  In the past, I’ve paid serious money for PIM packages.  Put Things Off is perfect for me.

Lose It! I’ve lost 26 pounds with this little gem.  It’s free.

I’m sure I could find similar apps for an Android phone, but I might not find anything as cheap, or as simple, or as elegant.

Anything else I use (iTunes, mail, contacts, calendar) is on every phone.  But do they sync nicely with Macs?  Probably not.

The rest of it I could probably live without — although I do need the better GPS that 3g offers.

I could switch to another smartphone.  They all have mail, contacts, and calendars. But I’ve used a Mac since it was first invented, and I’ve used PDA’s since they first came out — and iPhones sync better with Macs.  And I love Lose It! and Putting Things Off.

Alas, the new problem now is syncing anything at all.

I use Mac OS Tiger (10.4.11).  It’s a good OS.  The iPhone 4 requires OS 10.5 or above.

I already own 10.6 family pack — but it won’t install on my G5 (a 1.8 dual processor Powermac.  Top of the line in its day.  The big, expensive tower).

I can barely afford the phone, and I’m certainly not looking to buy a new computer.  There’s plenty of life left in the one I’ve got.

If I upgrade to plain Leopard 10.5, things would be cool — phonewise.  But that’s another $129 — and it’s likely to break my old version of Final Cut.

I spent a lot of time making films with this computer and although I seriously doubt I’ll ever do anymore video editing on this machine, I want access to those films — just in case Hollywood decides to pay me a million dollars for Coffee Therapy, with a few edits.

Upgrading the OS could break some of my graphics software also.  I depend on this system, on a daily basis, and don’t want to break it or spend money on lots of new packages.

So I’m stuck between generations.  Wanting the newer phone — not wanting to let go of my computer system.

I could forget about syncing altogether.  Not a great solution.

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.